Increased Error Rate
Incident Report for Phrase
Resolved
This incident has been resolved.
Posted Nov 13, 2017 - 09:12 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 13, 2017 - 08:05 CET
Investigating
We are currently investigating this issue.
Posted Nov 13, 2017 - 08:01 CET